Verification is currently underway for the maintenance items.
Posted Nov 27, 2025 - 23:34 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2025 - 22:00 UTC
Scheduled
Customer Impact: As part of our ongoing efforts to enhance the performance and reliability of our cloud infrastructure, we will be performing a scheduled maintenance operation. We do not expect any downtime during this window.
Thank you for your understanding and continued support.
Posted Nov 18, 2025 - 19:29 UTC
This scheduled maintenance affected: Global (Web Application & APIs, DSP Edge Services, SSP Edge Services, AdServer Edge Services, Header Bidder Edge Services, Data Pipeline & Reporting).